PLE forum
Pasting empty Cells from Excel to Ple4Win isn't always working - Printable Version

+- PLE forum (https://www.forum.ple4win.nl)
+-- Forum: Support (https://www.forum.ple4win.nl/forum-5.html)
+--- Forum: Ple4Win User Interface (https://www.forum.ple4win.nl/forum-29.html)
+--- Thread: Pasting empty Cells from Excel to Ple4Win isn't always working (/thread-629.html)



Pasting empty Cells from Excel to Ple4Win isn't always working - shaswin - 11-02-2020

Affected version: Ple4Win Professional 4.6.0

Scenario 1:
If you have a PLE input table like this:
[attachment=998]

And you want to paste the selected values from Excel from this:
[attachment=999]

Row 7 in the PLE input table will remain the same and doesn't go on empty if the selected range from Excel is pasted on the first row in PLE.

Scenario 2:
If you past a few or more blank rows from Excel to PLE input table on row 1 then the first row in PLE goes blank but the rows after it remains the same and doesn't change.


RE: Pasting empty Cells from Excel to PLE isn't always working - Dr. J Foerster - 12-02-2020

Thank you for reporting this issue.
I have looked into it using the new version 4.6.1 of Ple4Win, and I can confirm the behaviour, at least in part.

The problem is at least in part with Excel I am afraid Sad
I haven't completely figured out, but apparently Excel is "thinking for the user", i.e. the program tries to guess what the user might want to achieve and fails...

In your case the last line (the two empty cells) is simply not transmitted through the clipboard (at least not in the "view" that Ple4Win can handle). Apparently the program estimates that the user is not interested in the last row (sees it as unnecessary whitespace). In this mode Excel also discards multiple empty lines at the end.

And when fiddling around with the Excel sheet the Excel program sometimes suddenly decides that the empty cells are relevant and transmits them to the clipboard (as a TAB character followed by CRLF characters). At that point our program 'sees' the empty line and correctly imports it.

I have not yet found out why/how Excel decided to drop trailing empty cells, and why it suddenly "changes its mind".

I have assigned ticket no J-2363 to this issue, we will look into it, currently I have no idea if is fixable or not...


RE: Pasting empty Cells from Excel to PLE isn't always working - shaswin - 14-02-2020

Thanks for confirming this issue.